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1 Introduction

About Aren Payroll

Getting Started

Installation

Aren Payroll is a payroll program that runs in the Microsoft
Windows environment. It enables you to set up a database
containing pay details of the employees in your organisation.
Data entry is interactive with income tax, loan payments, pen-
sion fund balances and other calculated amounts updated and
displayed as you work.

The system produces several payroll reports such as payslips,
payroll summary, payroll control account, cash and cheque
lists as well as monthly and annual tax returns. All reports
are formatted for A4 paper so there is no need to buy special
stationery.

Access to the system requires a username and a password.
There is one permanent user who has unrestricted access to
the entire system. Other users can be added at any time and
assigned access to those functions they need to use.

The program can be configured to suit the needs of your organ-
isation. For example, you can define an unlimited number of
payments and deductions. You can also update the tables used
for calculating statutory deductions should the need arise.

Aren Payroll supports multiple organisations which is conve-
nient if you need to run the payroll of more than one organisa-
tion on a single computer. A separate licence key is required
for each organisation.

To use Aren Payroll you must first install it and configure it
to suit your needs. The rest of this section shows you how to
begin this process.

To install Aren Payroll:
1. Insert the installation CD in the CD drive.
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2. Run the program Pay815td|Install|setup.eze on the in-
stallation CD.

Waealcome to the Aren Payroll 8.1 Standard Edition |

Setup Wizard =)
Thea inztaller wil guide wou thicugh the steps iequired to instal Arsn Papoll 8.1 Standard Editon on
PO computer.

WARNING: This compubes program it protectad by copsight law and inbemational beaties.
Urnauthonzed duplicaton or disibubion of this program, or ary portion of ik, may result in sevane civil
or cimnal penakes. and vl be prozecuted fo the maamum extent possible under the law

< Back MNewt » Cancal

Figure 1.1: Setup Wizard

3. Follow the on-screen instructions that appear during the
installation process (figure 1.1).

The installation process copies the files required by Aren Pay-
roll to the folder you specify on the hard disk of your com-
puter. It will also add Aren Payroll and its Help file to the
Start menu.

Creating a Data Folder

1. Once the installation process is complete, run Aren Pay-
roll by selecting it from the Start menu.

AREN PAYROLL

Version 8.1
Standard Edtion for Uiganda
= Aren Softwore Lid, 1998-2022

[None]

| togn_ | Camcel | DataFoider. |

Figure 1.2: Start dialog box
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Logging In

2. In the Start dialog box that appears (figure 1.2), click on

Data Folder to open the Data Folders dialog box (figure
1.3).

Data Folders »

Available Folders

Creale. .. Select... Settings. ..

Target Folder
[Flon=]

Figure 1.3: Data Folders dialog box

. Click on Create in the Data Folders dialog to create a

new data folder in which to store Aren Payroll data. The
data folder must be located on the computer running
Aren Payroll, not on a network drive.

Make sure you have unrestricted access to whichever lo-
cation you choose, otherwise the software may not work

properly.

. Close the Data Folders dialog to return to the Start di-

alog.

. Within the Start dialog, click on Login to open the Login

dialog box.

. In the Login dialog box enter the username supervisor

(figure 1.4).

. You will be prompted to enter a password for use in

subsequent logins (figure 1.5). Enter a password of your
choice.

. A message box (figure 1.6) will then appear asking if you

would like to copy sample data. Choose No to proceed
to set up your organisation.
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Figure 1.5: Set Password dialog box

@ ‘Would you like to copy sample data to this data folder?

Mo
Figure 1.6: Sample data message box

5. The New Organisation dialog box is displayed next (fig-
ure 1.7). Type in the name of your organisation and the
month from which you want to start entering data.

mﬂ|l:lumﬂuaml.m

Memth | Jure vI
Year Iﬁ

Lo Cumency |Ugurd|| Shiling

Payrol Cumency |Uganda Shilng

Figure 1.7: New Organisation dialog box

6. Close the New Organisation dialog box to begin using



Moving On

Moving On

Aren Payroll.

Before entering employee data you need to finish setting up
the program. Section 2 explains how to do this. To enter
employee data refer to Section 3 which describes the employee
data tables in Aren Payroll.

After entering employee data you can view the reports de-
scribed in Section 4. With the exception of the muster roll
and payroll variance, all reports can be printed out on A4 pa-
per. Use the muster roll to export payroll data to an XML file
in Microsoft Excel format.

To close the current pay period and start a new one, run the
month end procedure described in Section 5. That section
also describes how to back up and restore data and create
bank transfer files.
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Before entering details about employees, use the Organisation
and System menus to configure the program. The Organi-
sation menu options apply only to the organisation that you
are currently working with whereas those of the System menu
apply to all organisations that you define.

Setting up the System

Users

Aren Payroll supports an unlimited number of users. There is
always at least one user, supervisor. The supervisor has access
to all functions including adding and deleting other users and
assigning such users access to program functions. By restrict-
ing users to only those parts of the program they need for their
work, it is possible to enforce separation of duties.

If you wish to add new users at this stage, do the following:

1. Select Users from the System Menu. This displays the
Users dialog box (figure 2.1).

Users X

Add,..

i

Password, .,

il

Claze

Figure 2.1: Users dialog box

2. Click on the Add button which brings up the User Iden-
tity dialog box (figure 2.2).

3. In the User Identity dialog enter the username. You may
also enter the user’s real name to help you identify him
or her in future.
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User Identity ®

Us=rrame christne
Last Maime Namazd

Other Names |f|"'$"l'"-‘
QK I Caniel |

Figure 2.2: User Identity dialog box

4. Close the User Identity dialog and choose Rights from
the Users dialog box. This displays the User Rights di-
alog box (figure 2.3).

User Rights for christine x
Fundtions
[V Edi emplves dala
¥ Modiy payrol fields Carel

¥ Set up apen organization

¥ Close pay period or morth
[ Aestore from backup

[ Add and delete orgarsabons

¥ Modiy tax tables

Figure 2.3: User Rights dialog box

5. Use this dialog box to specify the functions that you
would like the user to have access to.

6. Close the User Rights dialog box and choose Password
from the Users dialog box. This brings up the Set Pass-
word dialog box (figure 2.4).

Set Password far chiistine x
Passward | OK |
Carfim [ Cancel
Papsward —

Figure 2.4: Set Password dialog box

7. Enter and confirm the password if you wish. If you do
not enter a password at this stage, the user will be re-
quired to enter one when logging in for the first time.
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Banks

8. Close the Set Password dialog box. You can add more
users by repeating the procedure above.

9. Click on Close in the Users dialog box.

Aren Payroll comes with a comprehensive list of banks and
their branches. You will need this list for employees paid by
bank transfer rather than in cash or by cheque. The list is
shared by all organisations that you create. To review or mod-
ify it, select Banks from the System menu which will bring up
the Bank and Branches dialog box (figure 2.5).

*

Banks and Branches

ol Alied Bank

+ Bank of Baroda Add Bark

+ Bank of Uganda

# Barclays Bank Add Branch.
+ Cairo Intemational Bank
# Certenary Aural Dev Bark [elete
« Chbank

# Crane Bank
+ DFCL Bank
# Dsamond Trust Bank Chpe
+ Mational Bark of Commess
« Mg Bank

# Omant Bank

# Stantec Bank

# Standard Chartered Bank

+ Transafnca Bank

# Tropical Afnca Bank

« Liganda Commercial Bark

e

Figure 2.5: Banks and Branches dialog box

Statutory Deductions Parameters

PAYE and LST are calculated using brackets and rates that
are stored as tables. To view and update these tables select
PAYE Rates or LST Rates from the System menu (figure 2.6).
Refer to the Uganda Revenue Authority (URA) website for
the latest PAYE table.

The calculation of PAYE also depends on the low interest ben-
efit arising from loans made to employees by the organisation.
To update the statutory interest rates that are used in deter-
mining this benefit, select System > PAYE Parameters. This
will open the PAYE Parameters dialog box (figure 2.7).

Employer and employee contributions to NSSF are percentages
of gross pay. To modify these percentages select NSSF Rates
from the System menu. This opens the NSSF Rates dialog box
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Loweer Limt | Upper Limt | Tax Raterzy |
1 235000 000 [ eet |
235001 335000 10.00
335000 410000 20.00 Dislata
410001 10000000 30.00 Q
10000001 - Nore - 40,00 £

_ Cose |

Figure 2.6: PAYE Rates dialog box

Stalitery Interect Rate (4):

Iuly to Devamher 0.0
Jaruary bo June I 0.00
ok | conm |

Figure 2.7: PAYE Parameters dialog box

(figure 2.8). The special employer rate applies to contributions
made in respect of non-resident expatriates.

Contrbution o
Percentage of pensonable pay: EII

Starderd Employes Raks 500

Standard Employer Rate oo

Spedal Erphayer Rate 10,00

Figure 2.8: NSSF Rates dialog box

Working with Organisations

A single installation of Aren Payroll can support up to 99
different organisations. Each organisation requires a separate
licence key. The name of the organisation that is currently
open is displayed in the title bar of the main window.
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Adding a new Organisation

To add a new organisation select Add from the Organisation
menu. Use the New Organisation dialog box that follows (fig-
ure 2.9) to enter the name of the organisation and the month
from which you want to start entering data. On closing the
dialog box, the previous organisation is closed and the new
one opened.

Cancel

»
Mame |:I¢r\-:- Campary Lid OK I
__Cenedl |

Morth [re =]

Year |21:-::'2

Loes Cumency |.Ig.-|nda Shiling

Payrall Cumeney |J;EII'-:Ia Shilng

Figure 2.9: New Organisation dialog box

Opening another Organisation

To open a different organisation select Open from the Organ-
isation menu. This will bring up the Open Organisation di-
alog box (figure 2.10) provided there are other organisations
defined. Select the organisation you want to open from the

dialog box.
Open Organisation x
ok | Caneel

Figure 2.10: Open Organisation dialog box
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Deleting an Organisation

You can delete any organisation that is currently not open.
Deleting an organisation causes all its data files and folders to
be deleted. It is strongly recommended that you back up the
organisation’s database file before deleting it (see Section 5).

To delete an organisation:

1. Select Delete from the Organisation menu. To minimise
the risk of accidentally deleting an organisation you will
be required to enter your password (figure 2.11).

Delete Organisation by

Dieleting an anganeaton wil cause al s data
fies i be deleted . You are strongly advised to
l‘ back up thess fil=s before continung
o

i you ane sure you want jo continue, please
erfler your password below

Pasmpword |

Figure 2.11: First Delete Organisation dialog box

2. Next, a list of all organisations in the system, exclud-
ing the one that is open, will be displayed (figure 2.12).
Select the one you want to delete. Note that it is not pos-
sible to delete the organisation that is currently open.

Dielete Organisstion o

Derna Camparry Lid

ok | Caneel

Figure 2.12: Second Delete Organisation dialog box

3. In the two message boxes that follow, confirm that you
want to delete the selected organisation and destroy its
data files.
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4. Aren Payroll will then delete the organisation. A dia-
log box confirming that the deletion is complete will be
displayed.

Setting up an Organisation

To configure the organisation that is currently open, proceed
as follows:

Basic Organisation Information
Open the Basic Organisation Info dialog box (figure 2.13) from

the Organisation menu and enter the organisation’s address
and telephone number.

Basic Organisation Info »

Mame |Demo Restaurant Lid
Status: Mot icersed

Falder: D-\Payl 1horgl1

Morth | June - Year [2022
Addreas
P.O. Box [12345 Town [Hampala
Pag Cade Tetephone |555001
[ ok | Cancel

Figure 2.13: Basic Organisation Info dialog box

Also, confirm that you want to start entering payroll details
in the month and year shown in the dialog box. Once you
run the first month end procedure you will not be able to edit
either of them.

Licensing

Select Licence from the Organisation menu to open the Licence
dialog box (figure 2.14). Type in the licence key supplied by
your dealer. If you do not have a licence key, contact your
dealer or Aren Software Ltd.
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Payroll Info

Jobs

Licence X

Licence Number: [B812-3A5E

[ ok |  Cance Hep |

Figure 2.14: Licence dialog box

Open the Payroll Info dialog box (figure 2.15) by selecting
Payroll Info from the Organisation menu. FEnter the bank,
branch and account number for the organisation’s salary ac-
count. Also enter the organisation’s TIN, NSSF and HESFB

number.

Payroll Infao b4
ID Mumbers
oK I
i | Tos7B3SS
Cancs
HESF Mo, | F03042
HESEE Mo, | 320025
Curremdies

Local Currency | Uganda Shiling

Payroll Currency | Uiganda Shilling

Bankang

Bark |Standard Chartered Bank |

Branch |Speke Rgad -

Aecount Mo, | 012345678

smdefm|

Figure 2.15: Payroll Info dialog box

In this dialog box, the Standard File Interchange (SFI) Sender
ID applies to those who submit their payroll to the bank in
electronic form. Leave this field blank if you do not already
have an SFI Sender ID.

To set up the jobs available in the organisation, open the Jobs
dialog box (figure 2.16) by selecting Jobs from the Organisa-
tion menu.
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Administrative Units

Stations

Pay Groups

Jobs X

-

Asa. Restauram Manager 4
Badender

Bevarage Manager
Chaf

Cheef Accountant
Cleaner

Cook

Oinng Room Manager
Orecior

Execubive Chef

Head Batender

Dislete

Praperies...
Closa
Head Cleaner
Head Secunty

Head Wailer o
B | e

Figure 2.16: Jobs dialog box

Set up the administrative units (departments, sections, etc) in
your organisation. To do this select Units from the Organisa-
tion menu.

Set up the stations (branches) in your organisation. To do this
select Stations from the Organisation menu.

Pay Groups allow you to filter payment reports according to
how employees in your organisation are paid. For example,
the bank transfer report could be filtered by bank branch or
pay date.

To set up pay groups, select Pay Groups from the Organisation
menu.

Co-operatives and Pension Funds

Create co-operative societies that employees in the organisa-
tion belong to by selecting Co-operatives from the Organisa-
tion menu.

Similarly, set up pension funds by selecting Pension Funds
from the Organisation menu.
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Insurance Companies

Employee Profiles

General Options

If you need to deduct and remit insurance premiums, set up
the insurance companies involved by selecting Organisation >
Insurance Companies.

An employee profile defines attributes that are common to
a group of employees. These attributes are pay frequency,
basic pay type (i.e., salary, daily rate or hourly rate), standard
working hours (per day and per month) and whether overtime
is payable.

To create a profile, select Profiles from the Organisation menu
to open the Profiles dialog box (figure 2.17). If there is an
employee profile marked as default, all new employees added
to the payroll will be assigned this profile.

Ernpleyee Prafiles x
Sttt Add
Diglete
Properties...
ol

Figure 2.17: Profiles dialog box

Selecting Options > General from the Organisation menu opens
the General Options dialog box (figure 2.18). This dialog box
allows you to choose the sort order for employee data entry
forms. It also allows you to activate the Open Table dialog
box used for filtering form data by administrative unit, sta-
tion or pay group.

You can also specify when to purge old reports. Deleting old
reports saves space on the hard disk and reduces the size of
backup files.

In the PDF documents section you can edit the following pass-
words.
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Payroll Options

General Options

Ciata Enfry Forms
Sark By:

* Employee Mumber ™ Last Mame Cancel

i

[~ showi Open Table dialog bax Hel

Past Reports

Purge after| 5 years

PDF Doouments
Owireer Pasgword owner

Defeull Ussr Password |user

Figure 2.18: General Options dialog box

1. Owner Password: This password allows you to open any
PDF documents that you send by email. It should not
be disclosed to employees.

2. Default User Password: Employees use the user pass-
word to open PDF documents sent to them. It is usually
set to the last four digits of the employee’s TIN. Where
the TIN is missing, the default value you enter here is
used instead.

Selecting Options > Payroll from the Organisation menu brings
up the Payroll Options dialog (figure 2.19).

When Deduct PAYE before LST option is checked, PAYE
is calculated from the taxable pay without considering LST.
PAYE is then deducted from the gross pay before calculating
LST. With the option unchecked, LST is calculated from the
gross pay. It is then deducted from the taxable pay before
calculating PAYE.

The program can adjust PAYE in June for any overpayment
or underpayment in the course of the tax year. In the Payroll
Options dialog you can specify if the adjusted PAYE value can
be negative (indicating a refund). If this option is not selected
then the minimum adjusted PAYE will be zero.

To deduct LST check the option Deduct LST. This option
switches LST on or off for the whole organisation. For LST
to be deducted from an employee, it must be selected here
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Payroll Options x
PAYE
| Deduct PAYE befare LST E
[ Alow negative PAYE Cancel
Help
LsT
W Deduct LST
MNet Pay
For employee paid in cash:
(v Pay exact amount
(" Round down fo nearest Ush
Figure 2.19: Payroll Options dialog box
and switched on for the individual employee in the employee
master table.
Check this option for the first four months of the financial year
(July to October) when LST is payable.
Finally, you have the option to round down net pay for em-
ployees paid in cash by an amount that you specify. The excess
amount is carried forward to the next month.
Logos

Selecting Options > Logos from the Organisation menu brings
up the Logos dialog box (figure 2.20). This dialog box allows
you to select image files with the organisation’s logo for use
in payslips. These files must be in the images|logos folder
located within the organisation folder.

For printed payslips you can select a PNG or JPEG file. PNG
images are typically sharper than JPEG ones but they occupy
more space.

Select a JPEG file for payslips that are sent as email attach-
ments in PDF format. Attachments are restricted to 64 KB
so the logo file must be well below that size.
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—Printed Doouments
Bemave I

—Email Attachments
_Renoe |
ok | coe | Hep |

Figure 2.20: Logos dialog box
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3 Data Tables

Data for each employee is stored in two database tables, the
employee master table and the payroll transactions table. This
data is used to create the various report tables from which
reports are printed.

Employee Master Table

The employee master table stores static information about
each employee. It is accessed by selecting Employee from the
File menu. This brings up a data entry form in which you
enter details about each employee (figure 3.1).

Employes Master Table

Record 1 of 45 DRI Lihenzem, Stephen fAsega
[ Personal

e — Last Mame [Lhenzera

Payment |

Other Hames | Stephen Asega

Basic Pay

Creertime Gender |Male -
Housing Birth Date [ 15 Apr 1587

PAYE

ID Mo

MNS5F & LST

Co-aperatves Passport Mo.

Pensicn Funids Work Permit No.. |

Other

Figure 3.1: Employee Master Table form

You can add and delete employee records using the Add, Delete
and Terminate commands in the Record menu.

e The Delete command simply deletes an employee record.
It is only available if no month end procedure has been
run since the current employee was added.

e The Terminate command transfers an employee record
from the employee master table to the leavers report ta-
ble. This transfer takes place in the month end procedure
that follows the termination date specified by the user.
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Most of the fields in this table are optional. However, Em-
ployee Number, Last Name, Other Names, Job Title, Admin-
istrative Unit and Station are mandatory. If an employee is
paid by bank transfer, then Bank, Branch and Account Num-
ber are also mandatory. The optional fields are used in various
reports and should therefore not be left blank.

Payroll Transactions Table

The payroll transactions table stores earnings, deductions, ben-
efits, lump sum payments and refunds for each employee for
the current month.

FEarnings (or monthly cash earnings) are those cash payments
that relate to the current month e.g. basic pay or leave al-
lowance.

Benefits are private expenses of an employee that are paid by
the employer e.g. school fees, house rent or telephone bills.
These non-cash benefits are considered as income for tax pur-
poses.

Deductions are those amounts deducted from an employee’s
pay by the employer. Some of these are called statutory de-
ductions because the law requires the employer to deduct them
from the employee’s pay. The statutory deductions are PAYE,
NSSF, LST and tax on lump sum payments.

Lump sum payments are those cash payments that do not
relate to the current month alone. Some like gratuity and
bonuses have accrued over past months while others like ter-
minal benefits may relate to past or future months. We make
the distinction between lump sum payments and monthly cash
earnings because the two are treated differently when calcu-
lating income tax.

Refunds are payments made to an employee, e.g. travelling or
subsistence allowances, for business expenses incurred while
on duty. These payments are not income and are therefore
not taxable.

The payroll transactions table is accessed by selecting Payroll
from the File menu. This displays a data entry form (figure
3.2) where you enter earnings, deductions, benefits, lump sum
payments and refunds for each employee.

Statutory deductions and other calculated amounts such as
taxable pay, net pay and gross pay are updated as data is
entered. This makes the calculations more transparent and
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Payroll Fields

Payroll Transactions Table

Recard 1 of 45 DRO01 Libenzero, Stephen Asaga
Deductions BasicPay [# [ 1,950,000 J
Beneiia Overtme [~ [ 0 .|
Lump Sum Paymeants Houze Alowance ¥ Ii
Refunds
Srabutary Deductions l
Summary l
Taxabla Pay |

2,242,500

Figure 3.2: Payroll Transactions Table form

helps to reduce data entry errors. The payroll transactions ta-
ble can only include employees present in the employee master
table. Use the Remove command in the Record menu to sus-
pend employees from the payroll. Suspended employees can
be restored at any time using the Record > Add command.

At installation, the payroll transactions table has three earn-
ings (Basic Pay, Overtime and House Allowance), three de-
ductions (Rent, Overdraft Recovery and Rounding C/F), one
non-cash benefit (Low Interest Loan) and one refund (Round-
ing B/F). These fields cannot be deleted but you can add more
according to your needs.

To add, delete or edit fields, select Earnings, Deductions, Ben-
efits, Lump Sum Payments or Refunds from the File menu. A
data entry form will be displayed showing the field attributes
listed below (figure 3.3). To add or delete fields select Add or
Delete from the Field menu.

The following field attributes apply to all fields:

1. Field Name: The name of the field e.g. advance, shift
allowance.

2. Type: This is used to indicate permanent fields (e.g. ba-
sic pay and rent). It is also used to specify fields that
are calculated in a unique way (e.g. hourly pay and
daily pay) and those that are associated with a balance
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Deduchions

Fizld 3of 3

Fiedd Mame [Savers Penaon

Type  |Persion Contrbwon  v|  Parameters.

Amourt | Perceriage of Salary - | Fercantage..

I Preax deduction

Figure 3.3: Deductions form

that is updated and displayed by the system (e.g. loan
repayments and co-operative contributions). The type
advance is used to indicate advance payments so that
appropriate reports can be generated.

3. Amount: This attribute specifies how the amount paid
to or deducted from each employee is arrived at. It may
be keyed in, a percentage of salary, a function of the time
worked (basic pay, overtime, hourly pay and daily pay)
or amortised (loan repayments).

4. Static: Static fields retain their value when the month
end procedure is run, whereas non-static fields are reset
to their lower limit. This is only important for fields that
are keyed in. It saves you the trouble of having to key
in the amount earned or deducted each time the month
end procedure is run.

5. Tazable/Pre-tax deduction: For earnings the taxable at-
tribute specifies whether or not the payment is subject to
PAYE. In general, all cash earnings and most non-cash
benefits are taxable. Refunds are not taxable as they are
not a form of income.

The pre-tax deduction attribute indicates those deduc-

tions to be subtracted from gross income when calculat-
ing PAYE.

6. Pensionable: NSSF is calculated on the total pension-
able earnings. Uncheck the pensionable option to ex-
clude any earning from this calculation.

Depending on the selection for Type and Amount attributes
the following additional attributes may be available:
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1. Co-operative: The name of the co-operative associated
with the field (figure 3.4).

Co-operstive x

o Do Coop___Jd

Figure 3.4: Co-operative dialog box

2. Pension Fund: The name of the pension fund and other
details pertaining to the current field (figure 3.5).

Pension Fund Pararmeters x
MName | Savers d 0K I
Cancel

Employers Contnbution

| Percantage of Salary ;l
Percantage 10.00
[ Aoply Limke

Lower Limi ]
Upperlmt [ 0

Figure 3.5: Pension Fund Parameters dialog box

3. Insurance: The name of the insurance company associ-

ated with the field.

4. Limits: The upper and lower limits that the amount
paid or deducted should be restricted to (figure 3.6).

Lirnits =
Lawesr Limit ]
Upoer Lime 1000000

[ ox | Cancel |

Figure 3.6: Limits dialog box

5. Percentage: The percentage of monthly salary that should
be paid or deducted (figure 3.7).

6. Hourly Rate: The hourly rate to use for earnings that
are of the type Hourly Pay (figure 3.8).
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Pacertage | 10
W Aopiy Lmita
UpperLimt | 500000

Figure 3.7: Percentage of Salary dialog box

% Basic Pay Ratex | 050

7 Ky in rabe for sach employee

0K Cancel
' I

Figure 3.8: Hourly Rate dialog box

7. Daily Rate: The daily rate to use for earnings that are
of the type Daily Pay.
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Aren Payroll produces numerous reports as described below.
These reports can be viewed on the screen and printed out.
You can choose to print the entire report, a range of pages, or
just the page that you are currently viewing. Internal reports
can be sorted by either employee number or name.

You can view and print reports for current as well as past
months and years. You can also filter most reports by ad-
ministrative unit, station, pay group, bank, co-operative or
pension fund.

Reports may be printed on any printer connected to your com-
puter either directly or through a local area network. Because
all reports are formatted for A4 paper, the printer must be set
to print on A4.

1. To open a report select it from the Report menu and then
follow the on-screen instructions. For example, selecting
Report > Payslips opens the Open Payslips dialog box

(figure 4.1).
Open Payslips b
Pay Penod _ o
Year |2022 Canced
Momth |,.u-e il Neat |

Oiptions

fi

Figure 4.1: Open Payslips dialog box

2. To print the open report select Print from the File menu
which brings up the Print dialog box (figure 4.2). Use the
Setup button in this dialog box to configure the printer
you want to use.
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Nominal Rolls

Print X
Pririber: -
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Pages o print:
Setup...
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[ Current Page
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Figure 4.2: Print dialog box

3. Choose Close from the File menu to close the report.

1. Employees Roll: List of employees who are currently ac-
tive. It shows their job title, administrative unit and
station.

2. Joiners Roll: List of employees who joined the organi-
sation recently. It shows their job title, administrative
unit, station and start date.

3. Leavers Roll: List of employees who left in a given year.
It shows their final job title and administrative unit, the
date they left and the reason for leaving.

Monthly Payroll Reports

Overview Reports

The monthly payroll reports relate to a single month. Reports
for the current month are updated as you update the employee
master table and the payroll transactions table. Reports for
previous months can be viewed and printed out, but they can-
not be modified in any way.

1. Payroll Summary: Summarises earnings and deductions
for all employees.

2. Payroll Control Account: T-account listing total earn-
ings, deductions and net pay for all employees in the
organisation.
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Detail Reports

. Muster Roll: List of employees showing all earnings,

lump sum payments, refunds and deductions for the month.
Records in this report can be grouped by administrative
unit or station.

. Payroll Variance: List of employees showing the differ-

ences in the payments and deductions made in any two
pay periods. It is essentially the difference between the
muster rolls for the two pay periods.

. Gross Pay By Unit: List of administrative units showing

the staff count and total gross pay for each.

. Gross Pay By Station: List of stations showing the staff

count and total gross pay for each.

The muster roll and payroll variance can be viewed on the
screen or saved to an XML file but they cannot be printed

. Earning Report: List showing, for a particular earning,

how much each employee was paid.

. Deduction Report: List showing, for a particular non-

statutory deduction, how much each employee was de-
ducted. Depending on the type of deduction selected, a
loan or HESFB report may be printed instead.

. Loan Report: List of employees repaying a specific co-

operative or company loan. It shows the opening and
closing balances and a breakdown of the repayment amount
into interest and principal components.

. HESFB Report: List of employees paying back a HESFB

loan. For each employee it shows the reference number,
university name and amount deducted.

. Benefit Report: List showing, for a particular non-cash

benefit, how much each employee received.

. Lump Sum Report: List showing, for a particular lump

sum payment, how much each employee received.

. Refund Report: List showing, for a particular refund,

how much each employee received.
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Payments to Employees

1. Payslips: Slip giving a breakdown of the earnings and
deductions of each employee separately (figure 4.3). The
employer’s pension contribution and the pension fund
balance can be shown in the payslip if required. When
the balance is shown, it includes the employer’s portion
only if the option to print the employer contribution has
been selected.
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Figure 4.3: Payslips

2. Cash List: List of employees paid in cash showing their
employee number, name, net pay or advance payment
and a cash analysis of the payment amount.

3. Cheque List: List of employees paid by cheque showing
their employee number, name and net pay or advance
payment.

4. Bank Transfer Report: List of employees who are paid
by bank transfer showing their name, ID number, bank,
branch, account number and payment amount. The pay-
ment amount may be the net pay, an advance payment
or a bank loan repayment.

5. Coinage Summary Report: List showing the number of
coins and notes of each denomination that are required
for workers who are paid in cash. This information is
the same as the totals in the cash list but formatted so

that it can be used when withdrawing the cash from a
bank.
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Statutory Returns

1. IR10 Report: Uganda Revenue Authority (URA) monthly
tax return card. It is a list of employees that shows tax-
able income, monthly relief and PAYE for each employee.

To generate the equivalent file for filing PAYE returns
online, go to Procedure > PAYE Return. This will cre-
ate an XML file which should be opened with Microsoft
Excel and saved again as an Excel file.

2. NSSF Report: List showing the standard, special and
voluntary NSSF contributions for each employee.

The NSSF return file is available under the Procedure
menu (Procedure > NSSF Return).

3. LST Report: List of employees paying local service tax.
For each employee it shows TIN, gross pay and tax payable.

4. Lump Sums Tax Report: List showing tax payable on
lump sum payments for each employee.

5. Low Interest Benefit Report: List of employees who have
received a particular company loan at an interest rate be-
low the statutory rate. It shows the low interest benefit
these employees have received as a result.

Other Returns

1. Co-operative Report: List of members of a particular co-
operative society showing membership number, monthly
contribution and any other payroll deductions to be paid
to that co-operative.

2. Pension Report: List of members of a particular pension
fund showing membership number and employer and em-
ployee contributions to that pension fund.

3. Insurance Company Return: List of employee premium
deductions to be paid to a particular insurance company.

Annual Payroll Reports

Annual payroll reports relate to a calendar or tax year and
are available throughout the year. For the current year, the
information displayed relates to the months that have elapsed
so far. The reports are:

1. Payroll Control Account.
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2. Muster Roll.

3. Annual Pay Sheet: A report that, for each employee,
gives a summary of payments, deductions and benefits
for a whole year.

4. P9: URA form titled Tazx Deduction Card. Each P9
gives a breakdown of the income of an employee for each
month of the year and shows the amount of tax deducted.

5. P10: URA form titled Employer’s Certificate. It shows
the total tax deducted by the employer for each month
of the year.

6. P10A: URA form titled PAYE Supporting List for End
of Year Certificate. 1t lists the annual income and total
tax deducted from each employee.

7. NSSF Statement: A report that shows the employee and
employer contributions to NSSF for a single employee for
a calendar year.

8. LST Statement: A report that shows the employee monthly
pay and amount deducted for LST for a single employee
for a calendar year.

Other Reports

1. Bank Codes: A listing of banks, bank branches and their
sort codes drawn from the bank data tables.

2. Audit Trail: List that shows the date and time of each
login, backup, month end procedure and any other major
event. It also shows the user responsible for each event.
This report is only available to the supervisor.

Report Tables

Almost all reports are printed from report tables, not directly
from the employee data tables. Briefly, the report tables are:

1. Active employees report table
2. Annual leavers report tables
3. Monthly payroll report tables

4. Annual payroll report tables



Report Tables 33

Report tables are updated automatically by Aren Payroll. Use
the General Options dialog box (Organisation > Options >
General) to specify how long to keep these tables for.
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Backing Up

If any of your organisation database files is accidentally deleted
or corrupted you could lose all the data for that organisation.
Without an up-to-date backup you would be forced to key in
the data for the current month again. It is also likely that
you would be unable to recreate data for previous months and
years. It is therefore very important that you make regular
backups of your database files.

To back up the database file for the organisation that is cur-
rently open, select Back Up from the Procedure menu. You
will be prompted to specify the name and location of the
backup file to be created (figure 5.1).

G Backup et

T = PayBl ¢ Eacsup w o Search Back

Ceganise = M frolier = . [ +]
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Figure 5.1: Backup dialog box

The backup process copies all data relating to your organi-
sation to the backup file. Should you have set up more than
one organisation, you will need to back up each one separately.
Note that data that is shared by all organisations is not backed
up (e.g. list of banks and statutory deductions parameters).

When running the month end procedure you will be prompted
to back up. Though you can choose to proceed without doing
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so, it is recommended that you back up first. To encourage
regular back ups Aren Payroll prompts you to back up each
time you exit.

Restoring from Backup

In the event that an organisation database file is corrupted or
deleted, you will need to replace it from backup. You can also
use backup files to revert to an earlier month. This is especially
useful if you accidentally run the month end procedure.

To restore an organisation database file from backup, select
Restore from the Procedure menu then follow the on-screen
instructions (figure 5.2).

Restare »

Resgtoring from backup wil replace al the data
for this argarisation with that retreved from the
backup fil=. You are encouraged to back up
lhe argarisaion befare sartinuing

e

i you ane surs you want io conbinue, please
erfler your password below

FPaspword

oK I Caneel Hel

Figure 5.2: Restore dialog box

Creating a Bank Transfer File

A bank transfer file is an electronic version of the bank transfer
report. It is used by banks to process payments for employees
paid by bank transfer in place of the printed bank transfer re-
port. Aren Payroll can create bank transfer files for numerous
banks including Absa, Citibank, Stanbic and Standard Char-
tered.

1. To create a bank transfer file select Bank Transfer File
from the Procedure menu. The Save Bank Transfer File
dialog box appears (figure 5.3).

2. Specify the format of the bank transfer file to create
and the name of the payment field (usually net pay).
Depending on the file format, you may be able to specify
the date you want the bank transfer effected.
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Figure 5.3: Save Bank Transfer File dialog box

3. On closing the Save Bank Transfer File dialog box, a
standard Save As dialog box will appear. Use this dialog
to specify the name and location of the file to be created.

For further details on bank transfer files please contact your
bank.

Terminating an Employee

To terminate an employee, open the employee master table
and display the target employee. Next, select Terminate from
the Record menu. In the Terminate dialog box that appears
(figure 5.4), enter the termination date, the reason for leaving
and, if you like, some brief comments.

Terminate Lihenzero, Stephen Asega ®
30062022 - Cancel
Reason far Leaving
.Feng'led ad
Remarks

Figure 5.4: Terminate dialog box

The terminated employee will be removed from the employee
data tables in the next month end procedure that is later than
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or on the same day as the termination date. Once the employee
is deleted from the employee data tables his record will be
added to the leavers report table.

Termination can be reversed by selecting Record > Undo Ter-
mination as long as the terminated employee has not been
removed from the employee data tables.

Closing the Month

The month end procedure is used to close data entry for the
current month and begin a new one. It applies only to the
organisation that is currently open. It does the following:

1.

Saves all payroll information for the current month to
the monthly and annual report tables.

. Transfers terminated employees from the employee mas-

ter table to the leavers report table.

Deletes the current payroll transactions table and creates
a new one for the coming month.

Deletes any report data that is older than the limit set
in the General Options dialog box.

. Advances the pay period by one month.

. If the new month is July, it creates statutory deduction

tables for the new tax year.

The month end procedure should only be run after all reports
for the current month have been verified since, once it is run,
reports for that month cannot be changed.

To run the procedure:

1.

Select Month End from the Procedure menu. This op-
tion is only available if you have licensed the organisa-
tion.

. After reading the dialog box that appears (figure 5.5),

confirm that you want to close the month by entering
your password.

. You will now be prompted to back up your data and are

strongly encouraged to do so.

Once the back up is complete, the month end proce-
dure will automatically follow. Eventually, a message
box confirming its completion will appear.
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Figure 5.5: Month End Procedure dialog box
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Appendix A Importing Data

File Format

Keying in new employees into the payroll can be very time
consuming especially if there are many of them. As an al-
ternative, you can import employee data into the employee
master table from a text file.

The easiest way to create the input text file is to capture em-
ployee data in a spreadsheet and then save the spreadsheet as
a text file.

The format of the input text file is as follows:

1.

Plain text with data items separated by the tab character
(i.e. a tab-separated text file).

The first row of data is a header with the data items
Employee Number, Last Name, Other Names, ID Num-
ber, Job Title, Admin Unit, Station, Pay Rate, TIN and
NSSF Number.

From row two onwards, each row has data for a single
employee, i.e. employee number, last name, other names,
ID number, job title, administrative unit, station, pay
rate, TIN and NSSF number.

Note that:

1.

The first row (file header) is ignored. It is only included
for the convenience of the person preparing the input
file.

A row will not be imported if the employee number
matches that of a record already in the employee master
table.

. A row will also be skipped if any of the following data

items is blank: employee number, last name, other names,
job title, administrative unit, station.

Data will be imported into several data tables—employee
master, payroll transactions, jobs, adminstrative units
and stations.
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How to Import

5. Where a default profile has been defined, it will be ap-
plied to each record added to the employee master table.

1. Back up your data just in case you need to undo the
changes you are about to make (Procedure > Backup).

2. Select Procedure > Import Employees to open the first
Import New Employees dialog box (figure A.1).
Impart Mew Employees b4

mparting employee data from a text file may
modfy several data filea. | is advisable to
!' back up your dats befors cortinuing
o

i you ane surs you want io conbinue, please
erfler your password below

Fasword

ok | Cared Help

Figure A.1: First Import New Employees dialog box

3. Enter your password to open the second Import New
Employees dialog box.

4. Browse to the text file that you want to import data
from and click on Open.

5. Aren Payroll will read the text file and update the data
tables listed above. On completion, a confirmation mes-
sage box will be displayed. Close the message box.

To see which records were updated, refer to the log file im-
port.log located in the payroll data folder. Browse through
the data tables that should have been updated to confirm that
they were updated successfully.
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Aren Payroll can email payslips and P9s to each of the em-
ployees in the payroll. This provides an alternative to printing
individual payslips or P9s for each employee. The reports are
sent as password-protected PDF files.

In this section, we explain how to email payslips. Emailing
P9s works in exactly the same way.

Entering Email Addresses
Start by capturing the email addresses to send reports to.

1. Open the Employee Master Table form (File > Em-
ployee) and select the Other tab (figure B.1).

Employes Master Table
Record 1 of 45 DRI Lihenzem, Stephen fAsega

Personal

Emaloyment Email reports to:

Payment asegaifdemoresiaurant.co.ug
Basic Pay

Creertima

Housing

PAYE

NS5F & LST

Coroperatives

Persion Funids

Cither

Figure B.1: Employee Master Table form

2. For each employee, enter the address to email reports to.

3. Close the Employee Master Table form.

Setting Up Email Account

In order to send email, you need to set up your email account.
For this you require details of the outgoing mail server, also
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known as the SMTP server. Consult your IT department if
necessary or check the settings in the email software you use.

1. Select System > Email Account to open the Email Ac-

count dialog box (figure B.2).
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Figure B.2: Email Account dialog box

. Email Address: Enter your email address, say info@-

demorestaurant.co.ug or example@gmail.com.

. SMTP Server: Enter the name of the outgoing mail

server, e.g. mail.demorestraurant.co.ug or smitp.gmail-
.com. You can also enter the server’s IP address, e.g.
192.168.0.23.

. SMTP Port: The SMTP port is a unique number that

the mail server has set aside for outgoing mail. The most
common values are 25, 465 and 587. If your server uses
a secure (encrypted) connection, e.g. smip.gmail.com or
smip.mail.yahoo.com, try port 465 or 587. If it does not,
enter 25.

. Timeout: This is length of time the software should wait

for a response from the mail server before giving up.

. Use secure connection: Check this option if the mail

server uses a secure connection.
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10.

Sending Payslips

Authentication: You may select none (no account name
or password required), plain or login (requires account
name and password).

Account Name and Password: Enter the login name and
password for the mail server if you have selected login or
plain authentication.

Copy all emails to self: Check this option if you want to
receive a copy of all the reports you send.

Close the Email Account dialog box.

Now you are ready to email payslips to employees.

1.

Select Procedure > Email Payslips to open the Email
Payslips dialog box (figure B.3).

Ermnail Payslips x
Pay Perod _
OK I
Year |2022 Canced
Month [June -] Wt > |

Il

Options

Figure B.3: Email Payslips dialog box

Choose the pay period that you want then click OK. This
opens the Payslip Messages dialog box (figure B.4).

Click on Send to open the Message Range dialog box
(figure B.5).

Use the Message Range dialog box to send the current
message, all messages or a range of them. On comple-
tion, a message box showing the number of messages sent
will be displayed.

Close the Payslip Messages dialog box when you are
through.
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Figure B.4: Payslip Messages dialog box

Send:
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Figure B.5: Message Range dialog box

Details of the last mail session are saved in the log file email.log
located in the payroll data folder. Refer to this file if you have
any difficulty sending messages and to see which messages were
actually sent.

How to Open Payslips

Once a payslip is sent, the recipient will need one of the fol-
lowing passwords to open it.

1. Owner Password: This password is set in the General
Options dialog box (Organisation > Options > General).
Use it to open any payslips you send out.

2. User Password: This is usually the last four digits of the
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employee’s TIN. Where the employee’s TIN is missing,
it defaults to the value set in the General Options dialog
box. This is the password that employees should use.

You can modify the message that is sent to employees to in-
clude help on the password they will use to open the payslip.

1. Go to Procedure > Email Payslips to open the Email
Payslips dialog box.

2. Click on Options to open the Electronic Payslip Options
dialog box (figure B.6).

Electranic Payslip Options *
Message Print
¥ Include pasaword help B Jab Tite ok I
o Cancel
Son By numbers

o [ Payment mode
i*  Einpyes Mimber
k¥ PAYE breakdown

N

e W Loan breakdown
Layout W Employer pension
[ Ful page

[ Pension balance
[™ Edended header [ Coop balance
Haadngs W Loan balance
(" Back % Red

-

™ Green Blue

Figure B.6: Electronic Payslip Options dialog box

3. Check the option Include password help.
4. Close the Electronic Payslip Options dialog box.
5. Close the Email Payslips dialog box.
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Appendix C Formulae

Loans

Amortisation

Reducing Balance

The loan payment amount is uniform throughout the repay-
ment period. The portion of the payment amount that goes
towards repaying the principal increases with time as interest
payments reduce.

]
I—(1+r)"

Payment = l

where W = principal amount, n = total number of payments,
r = monthly interest rate (e.g. if annual interest rate is 15%,
r = (15/100)/12 = 0.0125).

The amount paid towards the principal is fixed throughout the
loan duration while interest payments reduce with time. Thus
the total payment amount reduces with time.

1
Payment = W' (/ + 7’)
n

where W’ = outstanding balance, n’ = number of payments
outstanding, » = monthly interest rate.



